x

Version 3.25.1 (Released at 12/05/2021)
- Small typo in tutorial 06 text has been fixed.

HYRCAN:
Version 1.75.3 (Released at 12/01/2021)
- Bug in memory allocation of support element has been fixed.
- Minor changes in Italian translation.


bug in opening a menu(Read 744 times)
bug in opening a menu on: May 11, 2021, 04:13:19 am
when i define materials, i can open the water table menu only by clicking near the center, as in the first image.

by clicking on the right (where it is supposed to click), as in the second image, menu cannot be opened.



Re: bug in opening a menu Reply #1 on: May 11, 2021, 09:09:44 am
it's strange because I don't have any issue. it drops as I click on it.

one thing I realized is that your fonts are slightly bigger and length of the label on the left side is out of range comparing to mine. that might be the source of issue.

I'll take a look and get back to you.
« Last Edit: May 11, 2021, 09:21:28 am by Roozbeh »



Re: bug in opening a menu Reply #2 on: May 11, 2021, 11:20:18 am
i've reduced the font size from 125% to 100%.

now it is possible to open the menu by clicking on the right but only when "none" (i.e. "nessuno" in the localization) is selected.
when "falda" is selected (like in the images i posted), menu can be opened only by clicking in the center.

if it helps, switching from "nessuno" to "falda" causes the shifting of the box on the left to create room for a new box (Hu parameter).

i use hyrcan on win7pro.
« Last Edit: May 11, 2021, 11:22:07 am by reversi »



Re: bug in opening a menu Reply #3 on: May 11, 2021, 12:46:11 pm
Qt has an option to automatically adjust the font size based on the screen resolution. I'll deactivate that to see if it get resolved. unfortunately, I don't have the Win7 to recreate the issue so I'll make the changes and send you the program to check.



Re: bug in opening a menu Reply #4 on: May 11, 2021, 01:09:39 pm
Hi reversi,

I just emailed you a link to temp exe file. please download the program and let me know if issue still exist.



Re: bug in opening a menu Reply #5 on: May 12, 2021, 11:49:08 am
sorry, but that is not the solution.
i don't know what it could be, but i can live with it  ;D

also, i understand that you can't.  8)