x

Version 3.25.1 (Released at 12/05/2021)
- Small typo in tutorial 06 text has been fixed.

HYRCAN:
Version 1.75.3 (Released at 12/01/2021)
- Bug in memory allocation of support element has been fixed.
- Minor changes in Italian translation.


Issue calculating FoS under various methods [Resolved](Read 96 times)
Issue calculating FoS under various methods [Resolved] on: October 06, 2021, 12:46:38 pm
Hello all,

I downloaded Hyrcan t test it out today and I tried a random file (script attached). I tried a few things that may have to do with it but here is the gist:

* I first made a slope under just over 30 degrees with a material of 30 degrees and got a reasonable result (abut 0.98)

* I then added a very weak layer with only 5kPa cohesion (the program does not seem to support undrained behavior, but since I don't have a piezometric line the total stresses should equal the effective stresses) and got a failre, which I expected

* Finally, I added all the other calculation methods and retried. To my surprise, the FoS is 0.000 in Spencer ad GLE, 0.001 for Janbu and the same as it was for Bishop.

* I tried the same geometry in Slide2 and got FoS values in the order of 0.3ish across the board, so there might be someting ging on.
« Last Edit: October 13, 2021, 07:06:02 am by Roozbeh »



Re: Issue calculating FoS under various methods Reply #1 on: October 07, 2021, 08:19:05 am
it seems like you modified the model multiple times back to back. is it possible for you to create a simple model that causes the issue?
this way I can follow the sequence and it's easier for me to debug. thanks.

also I think I know where the problem is coming from. Slide has a filtering process that ignores the surfaces with ma < 0.2 and also FS ~= 0.0 which I did not do. I'll add these filters and release the next version hopefully it will solve the problem.
« Last Edit: October 07, 2021, 09:51:50 am by Roozbeh »



Re: Issue calculating FoS under various methods Reply #2 on: October 07, 2021, 01:11:21 pm
Hi,

I just made a simpler version of the file. Hopefully that helps. I don't see a good way to search for the slip surface center/radus to test separately, but I'll try to reproduce the 0.000 FoS on my end. The umbers strike me as odd because they imply there's no resisting force (or a numerical error). Either way I hope that helps.